[FAQ CENTER トップ]
[Redhat Enterprise linux (EL) FAQ トップへ]

Redhat Enterprise linux (EL) FAQ


スポンサード リンク



【質問】パッケージが削除可能か確認(テスト)する


スポンサード リンク

【回答】 パッケージが削除可能か確認するには、 rpm -e コマンドに --test を付けて実行します。

【削除可能な場合】
# rpm -e --test postgresql-python-7.4.13-2.RHEL4.1

削除可能な場合は出力に何も表示されません。



【削除不可能な場合】
# rpm -e --test postgresql-libs-7.4.13-2.RHEL4.1

エラー: Failed dependencies:
libpq.so is needed by (installed) postgresql-python-7.4.13-2.RHEL4.1.i386
libpq.so.3 is needed by (installed) cyrus-sasl-sql-2.1.19-5.EL4.i386
libpq.so.3 is needed by (installed) dovecot-0.99.11-4.EL4.i386
libpq.so.3 is needed by (installed) perl-DBD-Pg-1.31-6.i386
libpq.so.3 is needed by (installed) postgresql-python-7.4.13-2.RHEL4.1.i386

削除が不可能な場合は上記のように依存関係のエラーが出力されます。



スポンサード リンク


(*)本ページは Redhat Enterprise Linux 4以後を想定しています。

最終更新日:2009/12/30

[Redhat Enterprise linux (EL) FAQ トップへ]
[FAQ CENTER トップ]


本サイト内掲載されている情報は、著作権法により保護されています。いかなる場合でも権利者の許可なくコピー、配布することはできません。 このページはリンクフリーです。(このページへの直接リンクも可能です。) Copyright(c) tooljp.com 2007-2012